Pull error: Unusable URI: it does not refer to this repository, 190001

Issue #204 duplicate
Eduard-Cristian Stefan
created an issue

I'm trying to pull from https://svn.kenai.com/svn/winsw~subversion/ and I get this error:

{{{ pulling from svn+https://svn.kenai.com/svn/winsw~subversion/ [r1] kohsuke: created a default svn structure abort: ('Unusable URI: it does not refer to this repository', 190001) [command interrupted] }}}

Incoming changes are listed ok:

{{{ incoming changes from https://svn.kenai.com/svn/winsw~subversion

revision: 1 user: kohsuke date: 2008-09-26T23:30:02.907651Z message: created a default svn structure

...

revision: 49 user: kohsukekawaguchi date: 2010-05-11T04:31:44.998927Z message: designated MIT license [command completed successfully Mon Sep 06 15:15:14 2010] }}}

I can checkout succesfully using a svn client.

Update 1: Other subversion repositories can be cloned without problems on the same PC:

Update 2: Checked at home (no proxy), I get the same error.

Comments (8)

  1. Dan Villiom Podlaski Christiansen

    Resolving this as a duplicate of #197. While the two are not exactly similar, the underlying issue is the same.

    Applying these two patches fixes it:

    I haven't checked if they apply cleanly to tip. Please note that they bump our version requirement for Subvertpy, but the relevant patch hasn't been applied to it yet.

    Duplicate of #197.

  2. Log in to comment