Pull errors: abort: unknown revision '327d8c072e94f13489ed1ae2aaa4be66584d00b2'!

Create issue
Issue #207 resolved
Gijs Kruitbosch created an issue

Unfortunately this is a private/company repo, so I can't just give you a URL, but here is some relevant info. The tail of the revmap looks like this:

58776 5a0dc7bd1e02a55652dfb17004000d0a79cb47a9

58779 7dfb4fcec11e3ddad05294d57776be82d7ba346e emoticons

58780 218211fd4ef19290b7015968160230f074a8736f release-1.6

58783 2021682f37cd51ef8c5589ec4a4e938ecf94712b

58786 327d8c072e94f13489ed1ae2aaa4be66584d00b2 emoticons

58801 4e01d021f9fc5dce5092bf8ce0fb747bf63e36fe release-1.6

58802 771d4c8c4e1755f2522046ec92b4baf46f58687a

The error says: abort: unknown revision '327d8c072e94f13489ed1ae2aaa4be66584d00b2'!

This is confusing to me because clearly the revision is listed in the revmap. The commit is on the 'emoticons' branch, so I don't understand "what's wrong", so to speak.

In case it's relevant, the last thing I did before this was using "hg svn genignore". This seemed to work fine, although it took a 'long time' (about a minute, I'd estimate). Pulls before then had worked fine (although it'd been a while). There are no local/outgoing changes.

If there's any commands I can run to diagnose this issue further, I'd be happy to - I am by all means no expert on hg or hgsubversion, and I apologize in advance if some basic/crucial info is lacking - I'm not sure what you need!

Comments (3)

  1. Gijs Kruitbosch reporter

    I just re-cloned the repo in a new directory, and that worked without errors. Still not sure what's up with the original copy of the repo.

  2. Augie Fackler repo owner

    (Reply via dur...@gmail.com):

    Try running 'hg svn rebuildmeta' in the broken copy, that might fix things.

  3. Gijs Kruitbosch reporter

    Gah, so for some reason bitbucket never mailed me about your comment - but that fixed it, indeed. Maybe we could add this hint for this error?

  4. Log in to comment