Mention both binding types upon import failure for Windows users

Issue #208 resolved
anatoly techtonik
created an issue

If there are no bindings installed, hgsubversion shows: {{{ ImportError: subvertpy 0.7.3 or later required, but not found. }}}

But there are no binaries of subvertpy for Windows. To convey that Subversion bindings are also acceptable, the error message should also display second ImportError. {{{ ImportError: Subversion 1.5.0 or later required, but no bindings were found }}}

I suggest to replace it with: {{{ ImportError: Required svn bindings were not found. Please install subvertpy 0.7.3 or later, or Subversion 1.5.0 or later. }}}

Comments (4)

  1. Augie Fackler repo owner

    (Reply via dur...@gmail.com):

    Yup, this is a known issue even on non-windows platforms. I'm currently mulling the text I want, but what you proposed looks pretty good.

  2. Log in to comment