hgsubversion can't detect SVN bindings.

Create issue
Issue #218 on hold
John Stephens created an issue

I'm running Subversion 1.6.12 (r955767) and Mercurial 1.6.3+20100826 on Mac OS X 10.5.8. I built and installed subvertpy from its source, and when I run {{{easy_install hgsubversion}}} I get the following error message:

{{{

ImportError: Subversion 1.5.0 or later required, but bindings for 1.4.4 found }}}

After installing hgsubversion from the source located here, I run {{{hg clone svn+http://python-nose.googlecode.com/svn nose-hg}}} to see if it's working, but I get another error message referring to SVN bindings:

{{{

abort: no compatible bindings available:

Subversion 1.5.0 or later required, but bindings for 1.4.4 found Subvertpy 0.7.4 or later required, but not found

Please install either Subvertpy or the Subversion Python SWIG bindings! }}}

Using Mercurial is the only thing I know about Python, so I believe I'm doing something wrong, but what?

Comments (4)

  1. Augie Fackler repo owner

    This means exactly what it says: Python can't find any bindings for the Subversion you have installed. Where is your Subversion installation located, and does it include SWIG bindings?

  2. Log in to comment