1. Augie Fackler
  2. hgsubversion
  3. Issues
Issue #225 invalid

Cloning Waf repository results in abort

Russel Winder
created an issue

I am using a clone of the HgSubversion repository my tip is 749:ec52205e5ed1. I tried to clone the Waf subversion repository at http://waf.googlecode.com/svn. It got to r9132 then: {{{ . . . [r9132] zeng.shixin: link_task could be not set yet abort: ('Temporarily unavailable', 135006) }}} If you try this then note that it takes a very long time to go between r8764 and r8765.

Comments (6)

  1. Dan Villiom Podlaski Christiansen
    • changed status to invalid
    • removed milestone

    I tried reproducing this locally. To begin with, I saw the same failures, but they seemed to go away later, and I was able to successfully clone the repository. Could you please try again and see if it works?

    That being said, this appears to be caused by something fishy with Google Code and that repository. If it persists — or you see something similar in the future — I'd suggest you get in touch with them. I'm marking this bug as “invalid” for now; we can always reopen it later if it really is our bug.

  2. Russel Winder reporter

    I just tried again given your experience, and it has now worked for me. Bizarre.

    Now that I am reminded, sorry for not remembering earlier, Jelmer Vernooij had serious problems with Google Code for the Bazaar Subversion plugin. If I recollect correctly, he had to put some hacks in place because Google Code folk seem unwilling to accept that they have a problem.

  3. Augie Fackler repo owner

    Curious. I'm not personally aware of any problems we have, but Jelmer should certainly talk to the Google Code guys (potentially again, if he already did, since they're generally pretty responsive.) bzr-svn does a *ton* of stuff that is extremely weird and non-svn-like, to the point of making what I'd call damaged histories.

    Google Code by its nature will have occasional transient issues - that's part of running a distributed system. In general, it's been fairly reliable for the last couple of years for me.

  4. Log in to comment