won't work on OS X (10.6) with repository using SASL

Create issue
Issue #248 invalid
sribe created an issue

I need to work with a repository (private, can't give you the link) which requires sasl authentication. On OS X apparently svn is built without sasl. There are some references on the web to this, perhaps in 10.5 the sasl lib was fubar'd. So, to start, svn on OS X will not connect to this repository.

I built svn from sources and installed into /usr/local/bin, which is on my search path at the head. So now svn works with the repository.

With Mercurial 1.7.3 installed from the OS X installer package, and hgsubversion installed, attempting to hg clone svn://... fails with "abort: None (SVN_ERR_RA_SVN_NO_MECHANISMS)", which is the same error that OS X default svn build gives.

I have gone back to my svn build and made swig-py and install-swig-py. I have moved libsvn_swig_py- to various locations and rebuilt/installed mercurial from sources. No matter what I try, I can't get hgsubversion to negotiate authentication method with this repository.

As a sanity check, I downloaded and easy_install'd hgsvn 0.1.8 and hgimportsvn worked fine with this repository.

Any suggestions what to try next?

Comments (3)

  1. Augie Fackler repo owner

    Make sure you're importing the svn libs you think you are when you install svn from source. Check hg version --svn and also look at the output of python -c 'from svn import core ; print core.__file__ to make sure the libraries are the ones you expect. If they're not, you may need to adjust PYTHONPATH or similar configuration knobs to force the correct libraries to be found first.

    Building svn with SASL support is a pain. Can you just grab some binaries from CollabNet or something?

  2. Augie Fackler repo owner

    Oh, I forgot to mention: hgimportsvn is a lousy check, as it doesn't use the bindings. It's therefore possible that hgimportsvn was using the correct svn binary but hgsubversion was still finding the libraries from the system install.

  3. Former user Account Deleted

    Hi Augie/Durin

    in my windows installation I get


    if i try to clone an svn repo (hg clon svn:...)

    have you any suggestions, what can I do?


  4. Log in to comment