1. Augie Fackler
  2. hgsubversion
Issue #309 resolved

Error 175002 when trying to push to SVN repo on GoogleCode

JD Fagan
created an issue

Not sure yet if this is hgsubversion problem or just underlying Mercurial issue. Figured I'd try here first..is this a bug, a mis-config on my part?

Ok, so was able to clone from SVN from GoogleCode. Then I created a branch using TortoiseHg to commit 1 file to add. Committed locally. Now trying to push back to SVN on GoogleCode bug get following errors depending on config (I do have commit access to the repo within GoogleCode):

  • svn+http (with username/email within URL)

{{{

!TortoiseHg Output Log

% hg --repository C:\Users\JDFagan\Repositories\CS TradeLink\TradeLink push svn+http://<my-email-address-in-url>@tradelink.googlecode.com/svn pushing to svn+http://<my-email-address-in-url>@tradelink.googlecode.com/svn C:\Users\JDFagan/.hgignore: ignoring invalid syntax 'regex' searching for changes ("Server sent unexpected return value (405 Method Not Allowed) in response to MKACTIVITY request for '/svn/!svn/act/<deleted-acct-GUID-here>'", 175002) [command returned code 255 Sun Oct 09 23:23:30 2011] }}}

  • svn+http

{{{

!TortoiseHg Output Log

% hg --repository C:\Users\JDFagan\Repositories\CS TradeLink\TradeLink push svn+http://tradelink.googlecode.com/svn pushing to svn+http://tradelink.googlecode.com/svn C:\Users\JDFagan/.hgignore: ignoring invalid syntax 'regex' searching for changes ("Server sent unexpected return value (405 Method Not Allowed) in response to MKACTIVITY request for '/svn/!svn/act/<deleted-acct-GUID-here>'", 175002) [command returned code 255 Sun Oct 09 23:33:10 2011] }}}

  • svn+https

{{{

!TortoiseHg Output Log

% hg --repository C:\Users\JDFagan\Repositories\CS TradeLink\TradeLink push svn pushing to svn repository svn not found [command returned code 255 Sun Oct 09 23:38:16 2011] }}}

Comments (3)

  1. JD Fagan reporter

    I did attempt svn+https but it appears the URL truncates at the +https for some reason looking at my last TortoiseHg Output Log (see above).

  2. JD Fagan reporter

    You're right - user error. My mistake. I was not using https in TortoiseHg synchronize section for the svn+https url (I was incorrectly using local for the svn+https url)

  3. Log in to comment