1. Augie Fackler
  2. hgsubversion
Issue #329 invalid

hg push to svn fails with error "forbidden"

Kannan V
created an issue

I am running hg repo on windows 2008 R2 (Vmware). Tortoise hg 2.2.2 and tortoise svn 1.7.2. my set up is: svn repo (remote site)=> hg master repo (clone) << couple of user hg repo I able to pull from svn, update/rebase etc, but when I push to svn it throws access forbidden error. I nuked the hg master repo and did a fresh clone, but got the same result. Last month I did a poc on my windows 7 machine on an earlier version of tortoise hg (2.0.x) and that worked against the same svn server. here is the error i am getting (after authentication):

searching for changes unknown exception encountered, please report by visiting http://mercurial.selenic.com/wiki/BugTracker Python 2.6.6 (r266:84297, Aug 24 2010, 18:13:38) [MSC v.1500 64 bit (AMD64)] Mercurial Distributed SCM (version 2.0.2) Extensions loaded: hgk, rebase, hgsubversion, histedit, children, mq Traceback (most recent call last): File "hg", line 42, in <module> File "mercurial\dispatch.pyo", line 27, in run File "mercurial\dispatch.pyo", line 64, in dispatch File "mercurial\dispatch.pyo", line 87, in _runcatch File "mercurial\dispatch.pyo", line 684, in _dispatch File "mercurial\dispatch.pyo", line 466, in runcommand File "mercurial\dispatch.pyo", line 738, in _runcommand File "mercurial\dispatch.pyo", line 692, in checkargs File "mercurial\dispatch.pyo", line 681, in <lambda> File "mercurial\util.pyo", line 458, in check File "mercurial\extensions.pyo", line 139, in wrap File "mercurial\util.pyo", line 458, in check File "C:\hgext\hgsvn\hgsubversion\wrappers.py", line 526, in generic return orig(ui, repo, *args, opts) File "mercurial\util.pyo", line 458, in check File "mercurial\extensions.pyo", line 139, in wrap File "mercurial\util.pyo", line 458, in check File "hgext\mq.pyo", line 3229, in mqcommand File "mercurial\util.pyo", line 458, in check File "mercurial\commands.pyo", line 4338, in push File "C:\hgext\hgsvn\hgsubversion\svnrepo.py", line 69, in wrapper return fn(self, args, *opts) File "C:\hgext\hgsvn\hgsubversion\svnrepo.py", line 84, in push return wrappers.push(self, remote, force, revs) File "C:\hgext\hgsvn\hgsubversion\wrappers.py", line 195, in push pushmod.commit(ui, repo, old_ctx, meta, base_revision, svn) File "C:\hgext\hgsvn\hgsubversion\pushmod.py", line 197, in commit props, newcopies) File "C:\hgext\hgsvn\hgsubversion\svnwrap\svn_swig_wrapper.py", line 338, in commit self.pool) File "libsvn\ra.pyo", line 584, in svn_ra_get_commit_editor2 svn.core.SubversionException: ("access to '/svn/sourcecode/!svn/act/3a5a0b1b-3f36-b741-abe4-38be73632411' forbidden", 175013) Thanks Kannan

Comments (3)

  1. Kannan V reporter

    the error was due to the incorrect casing of the path (especially in the root path, which is harder to notice). Fixing the case fixed the error. So, I am setting the state to invalid

  2. Olivier Renaud

    Hi, I'm hitting a similar problem. hg push gives me

    SubversionException: ("access to '/rep/memcad/!svn/ver/76417/trunk/src/.project' forbidden", 175013)

    .project is a simple text file, it just happens to be the first file in the root of my repository.

    It seems that you solved your problem by correcting the case of a path. What is this path you are referring to ?

    Thanks

  3. Olivier Renaud

    Sorry, please ignore my previous comment. After further investigation, it appears that our SVN server really forbids me the access to .project file. The fact that this is the very first file of a 6000 files repository is an unfortunate coincidence...

  4. Log in to comment