Tests fail on CentOS 6.4

Issue #388 invalid
David Johansen
created an issue

I tried running release 1.5 on CentOS 6.4 with the version of Mercurial and Python that comes with the OS and the tests failed with both SWIG and Subvertpy. Here's the output of hg version --svn with Subvertpy:

With Subvertpy:
Mercurial Distributed SCM (version 1.4)

...

hgsubversion: 77b22e5b4ea6
Subversion: 1.6.11
bindings: Subvertpy 0.8.10

With SWIG it's identical but just says SWIG for the bindings.

Is there anything that I can do to help further diagnose the issue?

Thanks,
Dave

Comments (7)

  1. David Johansen reporter

    Here's the results of running the test with the SWIG bindings. I had to run it as root, because it would freeze up on the "change binaries" part of the test_binaryfiles_stupid test when I ran it from my own account. I also replace test with repeating errors about ui and recurssion with ... to keep the file size down.

  2. Augie Fackler repo owner

    My guess is that you've got a subtely broken hg install, as you're getting a version of hg that lacks configint - make sure you're running with the version of hg you expect.

  3. David Johansen reporter

    My hope is to use hgsubversion with the packages that come with CentOS and that I won't need to install different/newer versions of hg or any other packages to get it to work.

    The version of hg on CentOS 6.4 is basically vanilla 1.4.3. There's a minor patch applied that changes all instances of "#!/usr/bin/env python" to "#!/usr/bin/python" so I don't think that should have any impact on hgsubversion. If you're interested, you can see the source rpm with the spec file at:
    http://vault.centos.org/6.4/os/Source/SPackages/mercurial-1.4-3.el6.src.rpm

    What can I do to help further diagnose the problem and hopefully get hgsubversion working out of the box with CentOS 6.4?

  4. David Johansen reporter

    I need to be able to run with the version of Mercurial that comes with the OS, so what can I do to help diagnose the source of this problem and get hgsubversion working?
    Thanks,
    Dave

  5. Augie Fackler repo owner

    At this point the version of hg that's on centos is old enough I don't have the motivation to fix this, but if someone shows up with a patch in hand I'll consider it.

  6. David Johansen reporter

    How big of a project do you think that this would be? If it's not a major undertaking, then I wouldn't mind trying to isolate the issue and submit a patch. How would I go about trying to isolate the cause of the issue?

  7. Log in to comment