SVN to Mercurial repo

Create issue
Issue #425 new
Former user created an issue

Hello, I've been following this link to get my repo changed from SVN to Mercurial:

http://thelandoftheblind.wordpress.com/2012/02/06/how-to-migrate-a-subversion-repository-to-mercurial/

I keep getting the following messages:

c:\hgsvn>hg clone --insecure --config ui.username=dbrossart --config "extensions .hgsubversion=c:\hgsvn\hgsubversion\hgsubversion" --config hgsubversion.authorma p=usermap.txt --config hgsubversion.defaulthost=https://dbrossart@ap-merc/hg/Gib son svn+http://appareo-repos:3660/svn/Gibson destination directory: Gibson Unknown exception encountered with possibly-broken third-party extension hgsu bversion which supports versions unknown of Mercurial. Please disable hgsubversion and try your action again. If that fixes the bug please report it to the extension author. Python 2.7.6 (default, Nov 10 2013, 19:24:24) [MSC v.1500 64 bit (AMD64)] Mercurial Distributed SCM (version 3.0.2) Extensions loaded: hgsubversion Traceback (most recent call last): File "hg", line 42, in <module> File "mercurial\dispatch.pyo", line 28, in run File "mercurial\dispatch.pyo", line 69, in dispatch File "mercurial\dispatch.pyo", line 138, in _runcatch File "mercurial\dispatch.pyo", line 819, in _dispatch File "mercurial\dispatch.pyo", line 599, in runcommand File "mercurial\dispatch.pyo", line 910, in _runcommand File "mercurial\dispatch.pyo", line 881, in checkargs File "mercurial\dispatch.pyo", line 816, in <lambda> File "mercurial\util.pyo", line 518, in check File "mercurial\extensions.pyo", line 151, in wrap File "mercurial\util.pyo", line 518, in check File "c:/hgsvn/hgsubversion\hgsubversion\wrappers.py", line 603, in clone orig(ui, source, dest, opts) File "mercurial\util.pyo", line 518, in check File "mercurial\commands.pyo", line 1299, in clone File "mercurial\extensions.pyo", line 196, in wrap File "c:/hgsvn/hgsubversion\hgsubversion\wrappers.py", line 592, in hgclonewra pper data['srcrepo'], data['dstrepo'] = orig(ui, *args, opts) File "mercurial\hg.pyo", line 400, in clone File "mercurial\localrepo.pyo", line 1860, in clone File "c:/hgsvn/hgsubversion\hgsubversion\svnrepo.py", line 77, in wrapper return fn(self, *args, opts) File "c:/hgsvn/hgsubversion\hgsubversion\svnrepo.py", line 105, in pull return wrappers.pull(self, remote, heads, force) File "c:/hgsvn/hgsubversion\hgsubversion\wrappers.py", line 434, in pull tbdelta = meta.update_branch_tag_map_for_rev(r) File "c:/hgsvn/hgsubversion\hgsubversion\svnmeta.py", line 547, in update_bran ch_tag_map_for_rev t_name = self.get_path_tag(p) File "c:/hgsvn/hgsubversion\hgsubversion\svnmeta.py", line 365, in get_path_ta g return self.layoutobj.get_path_tag(path, self.taglocations) File "c:/hgsvn/hgsubversion\hgsubversion\svnmeta.py", line 355, in taglocation s return self.layoutobj.taglocations(self.metapath) File "c:/hgsvn/hgsubversion\hgsubversion\layouts\standard.py", line 69, in tag locations self._tag_locations = util.load(tag_locations_file) File "mercurial\demandimport.pyo", line 103, in getattribute AttributeError: 'module' object has no attribute 'load'

Any idea what this is in reference to?

Comments (11)

  1. Dusty Brossart

    I get this: hg version: option --svn not recognized hg version

    output version and copyright information

    use "hg help version" to show the full help text

  2. Dusty Brossart

    Also, when I try to run the command to the local mirrored repo, I get this:

    abort: Unable to open an ra_local session to URL Unable to open repository 'file:///c:\hgsvn\svnmirror'

  3. Augie Fackler repo owner

    That would only happen if you didn't have hgsubversion installed and active. Make sure hgsubversion is installed and try again?

  4. Dusty Brossart

    From what I've been seeing, there isn't a way to install hgsubversion. One just clones the repo and then it runs under mercurial as an extension. Is that correct?

  5. Augie Fackler repo owner

    You still have to configure the extension in your hgrc. It can be run out of the hgsubversion clone, but you can also install it using 'pip install hgsubversion'.

  6. Dusty Brossart

    c:\hgsvn>hg version --svn Mercurial Distributed SCM (version 3.0.2) (see http://mercurial.selenic.com for more information)

    Copyright (C) 2005-2014 Matt Mackall and others This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    hgsubversion: 9490a3052935 Subversion: 1.6.16 bindings: SWIG

    I'm getting this now, but still the same errors.

  7. Augie Fackler repo owner

    Please run "hg --config extensions.purge= purge --all '**.pyc'" in your clone of hgsubversion and try again (this looks like a stale pyc issue). If taht doesn't help, please try a pristine clone of hgsubversion and see if that helps.

  8. Dusty Brossart

    I tried the command that you posted above, but it didn't work. I though maybe the "c" wasn't supposed to be in there so I changed the end to '**.py' and then it ran. I tried clone the repo again with the same results. So I decided to clear out hgsubversion and reclone it. That didn't work either; same error as before.

  9. Dusty Brossart

    So when I go down a step and try to run this command:

    c:\hggibson>hg clone --config ui.username=dbrossart --config "extensions.hgsubve rsion=c:\hgsubversion\hgsubversion" --config hgsubversion.authormap=c:\hgsvn\use rmap.txt --config hgsubversion.defaulthost=https://dbrossart@ap-merc/hg/Gibson s vn+http://ap-svn-01:3660/svn/Gibson/Trunk Gibson-trunk

    It looks like it's working until I get this error:

    abort: ("Unable to parse URL '/svn/Gibson/Trunk/Product/Unit Test/Gibson.Core.Te sts/Properties/AssemblyInfo.cs'", 175009)

    Edit: It looks like there is spaces in there, but that's from pasting it from command line

  10. Log in to comment