Empty history

Create issue
Issue #455 new
FlorianGeorge created an issue

I have a file with the following history:

  • (tip)
  • modified
  • modified
  • ...
  • modified
  • directory where the file is was re-added in svn
  • directory where the file is was deleted from svn
  • modified
  • ...
  • (start of svn)

The following commands produce zero output:

  • hg log [file] --verbose
  • hg log [file] --debug
  • hg log [file] --traceback

The command hg log [file] --profile produces some output but exclusively profiling related.

The command hg log [file] --follow shows the history from the most current commit up until the re-add commit.

Expected behavior:

  • hg log [file] displays history up until re-add commit. (same as svn history with "stop on copy/rename" active)
  • hg log [file] --follow displays history including history before delete/re-add commits. (same as svn history with "stop on copy/rename" disabled)

Comments (2)

  1. Augie Fackler repo owner

    Can you gin up a sample svn repo that we can look at for this? It seems pretty unlikely to be an hgsubversion problem, given that all we do is convert history and then let hg work on it.

  2. FlorianGeorge reporter

    I created a local SVN repository and made some commits that should result in the same situation, but unfortunately I am unable to clone it with hg.

    This is the output:

    V:\TestSVNRepoHgClone>hg clone V:\TestSVNRepoServer --verbose
    Abbruch: Projektarchiv V:\TestSVNRepoServer nicht gefunden!
    
    V:\TestSVNRepoHgClone>hg clone file:///V:\TestSVNRepoServer --verbose
    Abbruch: Projektarchiv V:\TestSVNRepoServer nicht gefunden!
    
    V:\TestSVNRepoHgClone>hg clone svn+file:///V:\TestSVNRepoServer --verbose
    Abbruch: Projektarchiv svn+file:///V:\TestSVNRepoServer nicht gefunden!
    
    V:\TestSVNRepoHgClone>hg clone "svn+file:///V:\TestSVNRepoServer" --verbose
    Abbruch: Projektarchiv svn+file:///V:\TestSVNRepoServer nicht gefunden!
    

    The error message means "Project Archive not found". I might just use the wrong syntax to clone a local svn. But as soon as I will use the correct syntax my next problem will probably be this: https://bitbucket.org/durin42/hgsubversion/issues/407/not-work-with-local-svn-with-db-format-6

  3. Log in to comment