Issue #85 resolved

Wrong remote ssh invokation on svn commands.

Anonymous created an issue

Hello:

I have a subversion repository I clone with a somewhat old version of hgsubversion, I've been using it almost correctly up to now.

I'm on hgsubversion tip now with mercurial 1.2. When I do hg svn incoming on this repository I see that the following command is run: {{{ ssh -o ControlMaster=no svn.debian.org svnserve -t }}}

Whereas according to hg svn info the svn repository is located at: {{{ svn+ssh://user@svn.debian.org/svn/pkg-kde/kde-extras/kvirc/trunk }}}

Pay attention to the username, it is not used in the above ssh command. This leads to an error since authentication can't happen.

Regards,

Comments (9)

  1. Anonymous

    Hello:

    Any news about this?

    I don't have much python experience, but I wouldn't mind looking the code to see if I can help with this. Do you think it would be possible for me to study this issue and eventually solve it? If you think so some pointer would be really appreciated.

    Regards,

  2. Anonymous

    Hello:

    This seems not solved yet, as I see it. execute this hg command: hg clone svn+ssh://user@svn.debian.org/svn/pkg-kde/kde-extras/kvirc/trunk/debian

    On another console execute: % ps aux |grep svnserve ssh -o ControlMaster=no svn.debian.org svnserve -t

    As you can see there's no trace of the username in the ssh+svnserve command.

    HTH.

  3. Anonymous

    Excuse me html editor spoiled my input. The hg command is:

     hg clone svn+ssh://user@svn.debian.org/svn/pkg-kde/kde-extras/kvirc/trunk/debian
    
  4. Anonymous

    Requested "hg svn version" output. I had to go to somewhere holding a mercurial repo to get it:

    hg: 1.3
    svn bindings: 1.6.1
    hgsubversion: ff69f1855086
    
  5. Anonymous

    Hello: I have to sincerely apologize for pushing a reopen of this. I didn't noticed that I needed to point the svn extension to the hgsubversion subdirectory and I was using an old version without notifying. This is indeed solved and should be closed. Sorry and thanks for the hard work on this extension.

  6. Log in to comment