Commits

Daniele Varrazzo committed 5533bc0

Show Psycopg version if not compatible.

Comments (0)

Files changed (1)

eventlet/psyco_eventlet.py

     """Configure Psycopg to be used with eventlet in non-blocking way."""
     if not hasattr(extensions, 'set_wait_callback'):
         raise ImportError(
-            "Support for coroutines is available only from Psycopg 2.2.0")
+            "support for coroutines not available in this Psycopg version (%s)"
+            % psycopg2.__version__)
 
     extensions.set_wait_callback(eventlet_wait_callback)