Arithmetic exception / SQL error 104

Issue #105 resolved
RedSnake
created an issue

Hello,

I tried to audit Atari Lynx no-intro set (1G1R) by using the corresponding dat file. After creation of database for this set, I tried to import the roms. Here is the fist kind of message I get (arithmetic exception):

Message Box.png

Note that I get that when the "rom files" icon is selected. In case I select the "database" icon instead, I get another kind of error message box (SQL 104):

Message Box 2.png

As a result, no roms are imported at all.

Please note that I tried importing 1 rom, and it was ok then when I added the other roms in rom folder, then hit refresh button, it crashed.

I thought maybe one of the rom contained some weird characters, but it isn't the case. Moreover, I tested it again by exchanging the first "ok" rom with other ones, and none made the bug appears.

So it seems problem occurs only for the second (and more) roms added whatever the first roms is.

Included in this ticket:

-crash log file

-database

-datfiles

Regards.

Comments (5)

  1. RedSnake reporter

    I checked other systems and this happened for pce-engine/turbografx16 and famicom disk system.

    For turbografx16 I managed to bypass the problem, because ROMCenter asked me whether I wanted to use pcengine.dll or not. If yes problem occurs, but by choosing no it doesn't.

    Note that for fds, an xml header is required by ClrMamePro, though I don't know if it is needed by ROMCenter (and I didn't see any option to do so)

  2. Eric Bole-Feysot repo owner

    This problem comes from the signature plugins. Plugins are used to calculate special crc like fds for example. But they doesn't work like they should with romcenter 4 (they are the same as in rc3). I don't know why, but I will develop a new system because the current plugins are 32b and prevent the build of the 64b version of romcenter. This will be for version 4.1. Until then, the next version will add a protection against these errors.

  3. Log in to comment