Clone wiki

opqit / Compiler_support

Compiler support

I have explicitly tested the following compilers:

  • MinGW g++ 4.5.1
  • Apple g++ 4.0.1, 4.2.1
  • Apple's llvm-g++ 4.2.1
  • Microsoft Visual C++ 2009, 2010

Version 0.1.1 incorporated a patch that was kindly submitted by Saulius Menkevičius. opqit should now work on Microsoft Visual C++ 2003 (aka MSVC7.1), though I cannot personally confirm this as I do not have a copy of this particular compiler.

Other compilers may work but they will need to have strong support for namespaces, templates and RTTI. Please let me know if you have success with a compiler not listed here.

Updated