Installation/Configuration of org-drill

Issue #16 resolved
Anonymous created an issue

I am currently running emacs 24.3.1 and org-mode version 7.3.9f and I cannot get the org-drill command to work...

I first customized the org-modules variable but activating the drill checkbox. That did not work, so I tried a manual installation but cloning this repository, adding the directory to my load-path and then requiring org-drill in my emacs init file. With the first customize-variable approach, it seems that nothing is actually loaded, with the manual approach I get a lisp-error which says that the system cannot find org-learn.

How can I resolve this issue so that I can start using org-drill?

Comments (5)

  1. Paul Sexton repo owner

    First of all, you are using quite an old version of org mode. The current version is 8.2.5. You will need to update to at least version 8 as there was a non-backwards-compatible change introduced to the 'org-schedule' function in that version (though I could put in a special case in the code if you are not able to update for some reason).

    Org-drill and org-learn both live in the directory "contrib/lisp/" under the main org directory. If you add this directory to your load-path then you should be able to use org-drill and it will be able to find org-learn. You don't need a clone of this repository unless you want to be 100% certain of always having the latest version.

    This is the setup in my dotemacs:

    (add-to-list 'load-path "/path/to/local/copy/of/org-drill")   ; only need if NOT using version that's packaged with org
    (add-to-list 'load-path "/path/to/org/contrib/lisp")   ; always need
    (require 'org-drill)
    (setq org-drill-maximum-items-per-session 30)

    You should then be able to start a drill session with M-x org-drill Let me know if this works.

  2. codekingplusplus NA

    Where is the "main org directory" typically located? I am running Ubuntu Linux and cannot find the main directory. I updated my org-mode version through the emacs package manager ELPA, to version 8.2.5. If I type org-version, into the mini-buffer, it tells me that it is located at /path/to/elpa/org-date/. So, I added this to my load-path but I still got nothing. I couldn't find .../contrib/lisp

    I ran the command: find -name "contrib/lisp" -type d

    It did not find any paths with "contrib/lisp" What can I do from here?

  3. Paul Sexton repo owner

    (I sent this reply via email earlier, but it doesn't seem to be showing up, so I've copied it here as a comment.)

    Look at the help for an org mode function or variable, such as org-version. It will tell you it is defined in 'org.el'. Click on the file name in the help buffer to load the file, then see what the file's home directory is.

    Alternatively use 'find / -name contrib/lisp' (you need to specify the root directory to search below, which is probably why it didn't work for you).

    It seems the problem you have is that you have not finished setting up org mode. I don't think you are experiencing any kind of bug with org-drill specifically. Once you get other org contrib modules working (eg once "(require 'org-learn)" works) then try org-drill and raise another issue if you still have problems with org-drill but not with other contrib modules. If you have more problems getting other contrib modules to load, ask for help on the org mailing list.

  4. Log in to comment