What does date picking do?

Issue #18 resolved
Anonymous created an issue

When I grade an answer with 0 to 2, a date picker will pop up and ask me to pick a date. What does this date that we select do? Should these graded be automated on rescheduling review dates as grades 3-5?

Comments (7)

  1. Paul Sexton repo owner

    Hi, this is because you are using org mode version 7.9.3 or older. That version is more than a year old, and newer versions of org mode have introduced incompatible changes to how the function "org-schedule" works. Install a more up to date version of org mode (recommended for other reasons as well) and you will no longer be prompted to enter a date when you fail a card.

  2. Tu Do


    I was using org from ELPA and it was the latest version: org-8.2.5h. However, I was also using org-plus-contrib, which contains org-drill 2.3.7. Despite installing org from ELPA, maybe it is still using its built-in org?

    I removed the org from ELPA and used the one from org git repo. Everything works fine now.


  3. marczz

    I had exactly the same problem with a close context. I am using emacs 24.3 and my org-mode come from elpa version 8.2.10 (8.2.10-5-g20dcd0-elpaplus) so it is more recent than the previous one, and a lot more recent than 7.9!, after reading this thread I tried a bare git version (release_8.3beta-534-g588ec5) by doing a

    make vanilla

    and it works ok. But it does not seem to come from an old "org-schedule" , my elpa package is org-plus-contrib 20141103 (the last one at the present date) wich include org-drill 2.3.7. The org-drill in the org-mode git was org-drill 2.4.1 and org-learn is unchanged between both releases.

    Keeping my elpa org version, I only loaded the new org-drill and it works perfectly. So yes it is now solved, but this didn't came from the incompatibility with old org-schedule that is now detected at load time by the last release.

    And for elpa users, no need to go to live development tree, just upgrade org-drill.


  4. Paul Sexton repo owner

    The issue absolutely did come from changes to org-schedule. The required arguments for the function changed after org mode 7.9. I updated org-drill to be compatible with the new version of the function, which made it incompatible with the old version of the function.

    Regardless, I'm glad it works for you now.

  5. marczz

    Of course, you are right Paul, the only thing I wanted to point out, is that the present package org-plus-contrib 20141103 contains the new org-schedule and an old org-drill, that causes the incompability, and that the users of elpa package, need only to upgrade org-drill. The next elpa package will probably fix it, but it should affect numerous users. added: 2014110 contains still the old 2.3.7!


  6. Log in to comment