issues installing `org-drill`

Issue #52 resolved
RSM
created an issue

Hi. there. Just reporting the installation guideline below is not working (at least for me) Is there something I'm missing?, I'd appreciate any clue. M-x customize-variables RET org-modules and then ticking the "drill" check box. (well I also tried with another pckge (org-learn.el) which installation is (also, I'd say) not (properly) documented. The output I got is:

Problems while trying to load feature `org-drill'
Problems while trying to load feature `org-learn'

Comments (4)

  1. Philipp Wasserman

    I also have problems with the installation guide: I have ubuntu 16.10 with Emacs from the ubuntu repositories (Emacs Version 24.5.1, org-version 8.2.10). For this post I started with an empty .emacs.d folder (and an empty init.el). M-x customize-variables doesn't work: I get "No apropos matches for customize-variables". So I did M-x customize, then searched for "modules". So I found org-modules. Then I tried to check the box in front of org-drill. But it didn't work. In the minibuffer I got this message: "Problems while trying to load feature `org-drill'".

    I did a manual install. I downloaded the latest version of org-drill.el from this repo and the latest version of org-learn.el and put them in a folder ".emacs.d/lisp".

    I put this into my init.el

    (add-to-list 'load-path "~/.emacs.d/lisp/")
    (require 'org-learn)
    (require 'org-drill)
    

    Now org-drill is working.

    I think your error report should contain more information. Which OS? Which emacs version? Which org version? Have you already tried with a minimial init.el?

    Have you seen this: http://stackoverflow.com/questions/34983106/how-to-install-org-drill

  2. Paul Sexton repo owner

    This seems like a general issue to do with installing and using Org mode's "contrib" packages. The stackoverflow thread you refer to also basically comes to the same conclusion.

    It sounds like you managed to get Org-Drill working in the end, judging by your final comment. I recommend you keep loading Org-Drill in this way. I find Org mode's module-loading functionality to be flaky so I don't personally use it.

    Those error messages ("No apropos matches", etc) are not mine - they are produced by Org mode or by other parts of Emacs, not by Org-Drill.

  3. Log in to comment