org-drill doesn't accept Near miss and worse

Issue #9 resolved
Anonymous created an issue

I was using org-drill to learn Swedish verbs in the last couple of months. When I tried it again today I ran into problems. Whenever I answer 0, 1 or 2 when getting asked "How well did you do?" emacs opens the calendar and asks me to choose a date (just as if I typed C-! in an org file).

How to reproduce the error: 1. Open the attached file. 2. Do M-x org-drill RET. 3. Press any key 4. Press 0,1 or 2.

This problem might be related to

I'm using GNU Emacs with Org Mode 8.0.3 (according to this version includes org-drill 2.3.7).

Comments (7)

  1. Lukas F.

    Yes, I am. No, I'm using the version that comes with the latest ELPA package of org-plus-contrib. However using the latest org-drill from this repository works indeed. Is it possible to integrate the current version of org-drill into the org-plus-contrib package on ELPA?

  2. Paul Sexton repo owner

    OK, I have pushed the latest version to the org-mode repository. I know nothing about ELPA so if it doesn't show up there you will need to contact whoever maintains that service.

  3. Log in to comment