Carpet should not require an MPI installation to work

Create issue
Issue #1018 new
Ian Hinder created an issue

Installing MPI could be a barrier to entry for new users, and PUGH is antiquated. There should be a way for new users to use Carpet for single-process runs without having to install MPI. There is a thorn NoMPI which provides a dummy MPI implementation which should be sufficient for Carpet to run. This thorn needs to be modified to fit in with the new MPI scheme. Specifically, it needs to provide an mpi.h file and the capability "MPI".

Keyword:

Comments (0)

  1. Log in to comment