McLachlan in ET/master needs an updated KrancNumericalTools/GenericFD

Create issue
Issue #1177 closed
Frank Löffler created an issue

McLachlan in ET/master needs (among other things) kisgn(), which is defined in Kranc/Tools/CodeGen/CodeGenCactus.m, but not mentioned in KrancNumericalTools/GenericFD/src/GenericFD.h.

Could it be that something needs to be updated from the Mathematica sources?

COMPILING /home/knarf/Cactus/arrangements/McLachlan/ML_BSSN/src/
/home/knarf/Cactus/configs/sim/build/ML_BSSN/ In function ‘void ML_BSSN_RHS1_Body(const cGH*, int, int, const double*, const double*, const double*, const int*, const int*, int, double* const __restrict__*)’:
/home/knarf/Cactus/configs/sim/build/ML_BSSN/ error: ‘kisgn’ was not declared in this scope


Comments (4)

  1. Ian Hinder
    • removed comment

    As far as I can tell, kisgn is defined in LSUThorns/Vectors/src/vectors.h (

        220 #define kisgn(a) (-42424242)

    This was added in August:

        Author: eschnett <eschnett@105869f7-3296-0410-a4ea-f4349344b45a>
        Date:   Thu Aug 16 18:52:18 2012 +0000
        Add dummy kisgn function
        git-svn-id: 105869f7-3296-0410-a4ea-f4349344b45a

    and seems to be related to this ticket:

    Do you have a clean checkout and a fresh build? I just tried building on my laptop with GCC, using origin/master branches of Kranc and McLachlan, and I don't see this error. I also tried in the ubuntu VM with vectorisation enabled, and it was also fine. Could this be an intel compiler issue?

  2. Peter Diener
    • removed comment

    I don't see this problem on my laptop using the Intel 12 compilers, so I don't think it's an intel compiler issue.

  3. Frank Löffler reporter
    • removed version
    • changed status to resolved
    • changed component to Other
    • removed comment

    Updating Vectors helped, thanks. Another confirmation that ticket:241 would be nice to have.

  4. Log in to comment