add version to LORENE library

Create issue
Issue #1833 closed
Frank Löffler created an issue

Now that capabilities can have versions, I propose to give the current LORENE external library the version 2014-04-18: the date the code was pulled from Lorene CVS and added to our repository (according to the log). Since Lorene is (still) in CVS and doesn't use release versions, a date is the best we can do.

Also, I propose to let the three thorns in the ET that use LORENE depend on that version in their configuration.ccl (less or equal than).

Keyword:

Comments (6)

  1. Roland Haas
    • removed comment

    Does the visible C++ interface change? If not I think we should not require a particular version of LORENE.

  2. Frank Löffler reporter
    • removed comment

    The only change I propose here is to give the existing LORENE thorn a version string. The library itself would not change.

    Also, following your suggestions from earlier, the actual version string should probably be 2014-04-18-1 - with the "1" indicating an ET-internal version.

  3. Frank Löffler reporter
    • removed comment

    Replying to [comment:2 rhaas]:

    Does the visible C++ interface change? If not I think we should not require a particular version of LORENE.

    Lorene did change it's C++ interface. We don't package that version yet. So, in order to create a "nice" error message for users trying to use the old interface with a newer Lorene thorn, we would have to let the using thorns depend on the old interface, e.g., the old version.

  4. Log in to comment