Cannot submit remotely

Create issue
Issue #194 closed
Erik Schnetter created an issue

I issued the command

$ ./bin/sim --remote numrel02 create-submit empty-i0000 --parfile=par/empty.par --procs=4 --walltime=1:0:0

which led to the local output:

DEBUG: Simfactory command: ./bin/../simfactory/lib/sim.py "--remote" "numrel02" "create-submit" "empty-i0000" "--parfile=par/empty.par" "--procs=4" "--walltime=1:0:0" DEBUG: Version 1109M The Simulation Factory: Manage Cactus simulations

Info: defs: /Users/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.ini Info: defs.local: /Users/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.local.ini Managing for remote machine: numrel02 Warning: No xauth data; using fake authentication data for X11 forwarding. DEBUG: Simfactory command: /home/eschnett/EinsteinToolkit-hg/simfactory/bin/../lib/sim.py "create-submit" "empty-i0000" "--parfile=par/empty.par" "--procs=4" "--walltime=1:0:0" DEBUG: Version exported The Simulation Factory: Manage Cactus simulations

Info: defs: /home/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.ini Info: defs.local: /home/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.local.ini Warning: could not load from restart id 0001, /home/eschnett/simulations/empty-numrel02-2011.01.09-21.39.00/output-0001/SIMFACTORY/properties.ini does not exist, broken restart Executing command: create_submit Parameter file: /home/eschnett/EinsteinToolkit-hg/par/empty.par Configuration name not specified -- using default configuration "sim" Configuration name not specified -- using default configuration "sim" Skeleton Created Job directory: "/home/eschnett/simulations/empty-i0000" Executable: "/home/eschnett/EinsteinToolkit-hg/exe/cactus_sim" Option list: "/home/eschnett/simulations/empty-i0000/SIMFACTORY/cfg/OptionList" Submit script: "/home/eschnett/simulations/empty-i0000/SIMFACTORY/run/SubmitScript" Run script: "/home/eschnett/simulations/empty-i0000/SIMFACTORY/run/RunScript" Parameter file: "/home/eschnett/simulations/empty-i0000/SIMFACTORY/par/empty.par" Active Id: -1 Active restart id: -001 Assigned restart_id of: 0000 Found the following restart_ids: [] Maximum restart id determined to be: -001 Determined submit restart id: 0 DEBUG: Previous ini file: /home/eschnett/simulations/empty-i0000/output--001/SIMFACTORY/properties.ini DEBUG: for machine option "allocation", using default value "None" writing to internalDir: /home/eschnett/simulations/empty-i0000/output-0000/SIMFACTORY writing to: /home/eschnett/simulations/empty-i0000/output-0000/SIMFACTORY/SubmitScript Executing submit command: sh /home/eschnett/simulations/empty-i0000/output-0000/SIMFACTORY/SubmitScript < /dev/null > /dev/null 2> /dev/null & echo $! Submit finished, job id is 17469

The simulation is created on the remote machine, but its stdout says:

$ cat *.out DEBUG: Simfactory command: /home/eschnett/EinsteinToolkit-hg/simfactory/bin/../lib/sim.py "run" "empty-i0000" "--machine=numrel02" "--restart-id=0" DEBUG: Version exported The Simulation Factory: Manage Cactus simulations

Info: defs: /home/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.ini Info: defs.local: /home/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.local.ini Called from the wrong location. Current directory is '/mnt/sdc1/simulations/empty-i0000/output-0000' but expected a subdirectory of '/home/eschnett'. It is also be possible that you need to correct your 'sourcebasedir' entry in the mdb entry for this machine.

Keyword:

Comments (2)

  1. anonymous
    • changed status to resolved
    • removed comment

    This problem has been fixed. I had a function called simlib.GetLocalEnvironment() that always attempted to determine the DirSuffix of the current path. This was erroneous and completely uncessary. I've removed this, and tested this scenario. It appears to work for me. Please reopen this bug if it does not solve the issue for you.

    This bug is fixed as of revision r1110

  2. Log in to comment