track website error

Create issue
Issue #2009 closed
Roland Haas created an issue

Hello all,

two times in the last couple days I have received the following error when trying to login to the trac website:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 436, in send_error
    data, 'text/html')
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 803, in render_template
    message = req.session.pop('chrome.%s.%d' % (type_, i))
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 212, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 298, in _get_session
    return Session(self.env, req)
  File "/usr/lib/python2.4/site-packages/trac/web/session.py", line 156, in __init__
    if req.authname == 'anonymous':
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 212, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 157, in authenticate
    authname = authenticator.authenticate(req)
  File "/usr/lib/python2.4/site-packages/TracAccountManager-0.2.1dev_r4679-py2.4.egg/acct_mgr/web_ui.py", line 429, in wrap
  File "/usr/lib/python2.4/site-packages/TracAccountManager-0.2.1dev_r4679-py2.4.egg/acct_mgr/web_ui.py", line 439, in authenticate
  File "/usr/lib/python2.4/site-packages/TracAccountManager-0.2.1dev_r4679-py2.4.egg/acct_mgr/web_ui.py", line 466, in _remote_user
  File "/usr/lib/python2.4/site-packages/TracAccountManager-0.2.1dev_r4679-py2.4.egg/acct_mgr/api.py", line 140, in check_password
  File "build/bdist.linux-x86_64/egg/tautua/trac_plugins/security/ldapauth.py", line 35, in check_password
  File "/usr/lib64/python2.4/site-packages/ldap/ldapobject.py", line 175, in simple_bind_s
    msgid = self.simple_bind(who,cred,serverctrls,clientctrls)
  File "/usr/lib64/python2.4/site-packages/ldap/ldapobject.py", line 169, in simple_bind
    return self._ldap_call(self._l.simple_bind,who,cred,EncodeControlTuples(serverctrls),EncodeControlTuples(clientctrls))
  File "/usr/lib64/python2.4/site-packages/ldap/ldapobject.py", line 94, in _ldap_call
    result = func(*args,**kwargs)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-13: ordinal not in range(128)

Typically the error goes away when I try again (sometimes multiple times).

Keyword:

Comments (3)

  1. Frank Löffler
    • removed comment

    Likely this is a symptom of ldap problems we have had in the last few days here. Please let me know whenever you see this (just ping the ticket). I'll leave it open for now.

  2. Log in to comment