Compiling on mike2 fails b/c C compiler cannot compile code

Create issue
Issue #2292 closed
Former user created an issue

Trying to compile the future ET_Mayer on Mike2 (HPC CCT LSU) I get failures during the CST stage:

checking whether the C compiler (/home/compilers/Intel/parallel_studio_xe_2018.0/compilers_and_libraries_2018/linux/bin/intel64/icc -g -xHOST -align -std=gnu99 -U__STRICT_ANSI__ -ansi_alias -gcc-name=/usr/local/compilers/gcc/4.9.2/bin/gcc -Wl,-rpath,/usr/local/compilers/gcc/4.9.2/lib64) works... no
configure: error: installation or configuration problem: C compiler cannot create executables (see configs/sim/config-data/config.log for details).

and config.log contains:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:912: checking host system type
configure:938: checking for mawk
configure:938: checking for gawk
configure:1007: checking whether make sets ${MAKE}
configure:1072: checking whether the C compiler (/home/compilers/Intel/parallel_studio_xe_2018.0/compilers_and_libraries_2018/linux/bin/intel64/icc -g -xHOST -align -std=gnu99 -U__STRICT_ANSI__ -ansi_alias -gcc-name=/usr/local/compilers/gcc/4.9.2/bin/gcc -Wl,-rpath,/usr/local/compilers/gcc/4.9.2/lib64) works
configure:1089: /home/compilers/Intel/parallel_studio_xe_2018.0/compilers_and_libraries_2018/linux/bin/intel64/icc -o conftest -g -xHOST -align -std=gnu99 -U__STRICT_ANSI__ -ansi_alias -gcc-name=/usr/local/compilers/gcc/4.9.2/bin/gcc -DMPICH_IGNORE_CXX_SEEK -Wl,-rpath,/usr/local/compilers/gcc/4.9.2/lib64 conftest.c  1>&5
/tmp/icc5Wh1JP.o: In function `main':
conftest.c:(.text+0x1a): undefined reference to `__intel_new_feature_proc_init'
configure: failed program was:

#line 1084 "configure"
#include "confdefs.h"

main(){return(0);} int PilotMain(){return(0);}

Comments (12)

  1. Peter Diener

    I can not reproduce this even with an almost empty environment (disabling loading the modules I would normally load). My build starts normally and thorns are being compiled as I write this.

    @Roland Haas What does your environment look like?

  2. Roland Haas

    @Peter Diener It should not be anything special since the first thing I did was rm -rf * in my $HOME and I really have not done anything on mike for a long time. All the dotfiles look sane to me.

    My .soft file reads just @default and both .bashrc and .bash_profile look like vanilla versions to me. I am not quite sure how to make softenv show me a list of loaded modules. I could provide the output of env but that may be too much. I have made my $HOME on mike2 readable if you would like to poke around.

    I have tried both running locally on mike as well as using simfactory’s remote option:

    simfactory/bin/sim --remote mike build
    

    and both give the same result.
    The only non-standard setting for mike in simfactory that I have is setting an allocation.

  3. Roland Haas

    Let me try this. Currently when I type module it reports -bash: module: command not found….

    Alright, running the command indicated in the help page seems to have fixed the issue, or at least simfactory is now compiling. I will close this ticket once it is done compiling.

    So this seems to have been a case of bit-rot.

  4. Peter Diener

    @Roland Haas I got compilation and linking to work by specifying modules to load in the mike.ini machine file even with an environment with no modules loaded. I also tested that the testsuite runs. Do you wanna test if this works for you or should we just close the ticket?

  5. Log in to comment