TOV_ET tutorial Segfaults when running in Windows 10 WSL

Issue #2592 invalid
Former user created an issue

I'm using a wsl machine mounted in windows 10 and i can't seem to make the tutorial work. It always segfaults after a definite time (time 112.000), i tried allocating more memory but it doesn't seem to resolve the issue, also i checked that the sim doesn't take any large amounts of RAM. It used to work on win 11 but i rolled back to win 10 but it doesn't anymore. I completely reinstalled my wsl machine when i got back on win 10. Either way i'm reporting the backtrace

1. CarpetLib::signal_handler(int)   [/home/sam/simulations/tov_ET/SIMFACTORY/exe/cactus_sim(_ZN9CarpetLib14signal_handlerEi+0xb3) [0x56013afdf833]]
2. /lib/x86_64-linux-gnu/ [0x7fbef30cd210]
3. /home/sam/anaconda3/lib/ [0x7fbef3522c73]
4. /home/sam/anaconda3/lib/ [0x7fbef352329e]
5. /home/sam/anaconda3/lib/ [0x7fbef3521900]
6. /home/sam/simulations/tov_ET/SIMFACTORY/exe/cactus_sim(prim2conpolytype_+0x3f6) [0x56013b464e06]
7. /home/sam/simulations/tov_ET/SIMFACTORY/exe/cactus_sim(+0xb9e28f) [0x56013b46628f]
8. /home/sam/anaconda3/lib/ [0x7fbef329ce22]
9. /home/sam/simulations/tov_ET/SIMFACTORY/exe/cactus_sim(prim2conservativepolytype_+0x54f) [0x56013b472fef]

Comments (8)

  1. Roland Haas

    @Steven R. Brandt did you have any luck reproducing this? If not I would close as “invalid”.

  2. Sam

    Hi, i was the OP of this thread. At the time i managed to solve it by deactivating the anaconda environment before running, I do not really know the reason why that was the problem.

    Either way, I eventually switched to linux completely and i built ET without issues on the same device, so problem solved.

    Thank you for the help.

    Regards, Samuel

  3. Roland Haas

    Ok. My best guess would be some interaction between anaconda and the system libraries. I will close as “invalid” in that it could not be reproduced.

    Thank you for the update.

  4. Log in to comment