HDF5 thorn expects sz library but does not handle sz.2

Create issue
Issue #347 closed
Ian Hinder created an issue

The HDF5 thorn adds libsz to the list of libraries to link. When installed using fink, the szip library is called libsz.2.dylib and there is no libsz.dylib. I don't understand library versioning particularly well. How should this be dealt with?

Keyword: ExternalLibraries/HDF5

Comments (3)

  1. Erik Schnetter
    • removed comment

    The file libsz.2.dylib is a run-time library, it cannot be used for linking. It is likely that you need to install the "development package" corresponding to the package providing libsz.2.dylib. It may also be that libsz.dylib or libsz.a is installed in a different directory.

  2. Ian Hinder reporter
    • changed status to resolved
    • removed comment

    Thanks. The hdf5-18 package depends on the szip-shlibs package, but not on the szip package. The latter is required to get the object files needed for static linking. When you install the szip package, it works again.

  3. Log in to comment