Cannot add attachments to tickets "IOError: Client read error (Timeout?) "

Create issue
Issue #492 closed
Ian Hinder created an issue

This evening I am unable to add attachments to any tickets. After selecting the attachment file, clicking on the button to actually upload it leads to the error message below. This has happened before, but in those cases the attachment was added successfully despite the error message. In this case, no attachment appears. I have tried several times, and none of them worked.

Mod_python error: "PythonHandler trac.web.modpython_frontend"

Traceback (most recent call last):

File "/usr/lib64/python2.4/site-packages/mod_python/apache.py", line 299, in HandlerDispatch result = object(req)

File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 149, in handler gateway.run(dispatch_request)

File "/usr/lib/python2.4/site-packages/trac/web/wsgi.py", line 89, in run response = application(self.environ, self._start_response)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 481, in dispatch_request return _dispatch_request(req, env, env_error)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 557, in _dispatch_request send_internal_error(env, req, sys.exc_info())

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 635, in send_internal_error description_en = get_description(lambda s, **kw: safefmt(s, kw))

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 631, in get_description req_args=pformat(req.args), sys_info=sys_info,

File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 212, in getattr value = self.callbacksname

File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 195, in 'args': lambda req: arg_list_to_args(req.arg_list),

File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 212, in getattr value = self.callbacksname

File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 560, in _parse_arg_list fs = cgi.FieldStorage(fp, environ=self.environ, keep_blank_values=True)

File "/usr/lib64/python2.4/cgi.py", line 526, in init self.read_multi(environ, keep_blank_values, strict_parsing)

File "/usr/lib64/python2.4/cgi.py", line 646, in read_multi environ, keep_blank_values, strict_parsing)

File "/usr/lib64/python2.4/cgi.py", line 528, in init self.read_single()

File "/usr/lib64/python2.4/cgi.py", line 661, in read_single self.read_lines()

File "/usr/lib64/python2.4/cgi.py", line 683, in read_lines self.read_lines_to_outerboundary()

File "/usr/lib64/python2.4/cgi.py", line 710, in read_lines_to_outerboundary line = self.fp.readline()

File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 50, in readline return self.req.readline(size)

IOError: Client read error (Timeout?)

Keyword:

Comments (10)

  1. Ian Hinder reporter
    • changed status to resolved
    • removed comment

    Adding attachments works again, though is sometimes very slow and occasionally times out. Nothing changed on the server so it must have been an intermittent problem.

  2. Frank Löffler
    • removed comment

    Still works for me, really fast as well. Can you try to find out if there is some correlation with the failures and something else? Or maybe another browser would work at times another would not?

  3. Ian Hinder reporter
    • removed comment

    It looks very similar - I will try the workarounds suggested. That was from many years ago though.

  4. Ian Hinder reporter
    • removed comment

    Yes. Nothing has changed. If you look at the link in comment:6, they talk about a problem with Safari not being able to reuse an http connection for a file upload. In that ticket, they seemed to conclude that it was fixed in Safari years ago, but we still see the issue. There is a work-around, which is to wait on the file upload page for one minute.

  5. Frank Löffler
    • changed status to resolved
    • removed comment

    I don't think we can change trac to workaround an issue with Safari. It would be nice though to know if this works for some Safari users and which version they use.

  6. Log in to comment