Running on Damiana fails

Create issue
Issue #79 closed
Barry Wardell created an issue

The compute nodes on Damiana are named nodeXXX, which does not match the aliaspattern for Damiana in the mdb. The quick fix is to change the aliaspattern to:

aliaspattern = ^(((login-)?damiana)|(sl-\d\d)|node\d\d\d)(.aei.mpg.de|.damiana.admin)?$

although this might interfere with other machines which also have their compute nodes named nodeXXX. A better fix would probably be to add a --machine=... option when running so that SimFactory does not need to guess which machine it's on from the aliaspattern.

I believe a similar problem also affects Kraken.

Keyword:

Comments (5)

  1. Barry Wardell reporter
    • removed comment

    I've just tested this out with damiana and a fresh checkout of the PYSIM_2010 branch. I used the command:

    sim create-submit --machine damiana ...

    and it still doesn't seem to work. I still get the error:

    Error: Could not determine local machine. Is an entry for node111.damiana.admin setup?

    PS. Sorry, I didn't receive any emails from Trac so didn't realise you had replied to this until now.

  2. Barry Wardell reporter
    • removed comment

    I manually edited the damiana submit script and added "--machine=damiana" to the run line and my job now starts OK. I think this ticket can be closed once #130 is closed.

  3. Log in to comment