add OPTIONAL dependency on MPI to HDF5

Create issue
Issue #985 closed
Roland Haas created an issue

With #980 thorns using a compiled HDF5 version that has parallel MPI enabled (such as the the one on my debian system which I need because either PetSC or libsiloh5 wanted it) do not compile anymore. Adding

OPTIONAL HDF5
{
}

to ExternalLibraries/HDF5's confguration.ccl fixes this. Ok to apply?

Keyword: HDF5

Comments (5)

  1. Erik Schnetter
    • changed status to open
    • removed comment

    This is okay if it does not break the build on other systems. Please apply; we will revert if there are problems.

  2. Log in to comment