pylint / README

README for PyLint

Pylint requires the logilab-astng (version >= 0.21.0), logilab-common
(version >= 0.53).


From the source distribution, extract the tarball and run ::

    python install

You'll have to install dependencies in a similar way. For debian and
rpm packages, use your usual tools according to your Linux distribution. 

More information about installation and available distribution format
may be found in the user manual in the *doc* subdirectory.

Look in the doc/ subdirectory.

Comments, support, bug reports

Project page on :

Use the mailing list. Since we do not have
publicly available bug tracker yet, bug reports should be emailed
there too. 

You can subscribe to this mailing list at

Archives are available at

* Sylvain Thenault: main author / maintainer
* Alexandre Fayolle: TkInter gui, documentation, debian support
* Emile Anclin: maintainer
* Mads Kiilerich: various patches
* Brian van den Broek: windows installation documentation
* Amaury Forgeot d'Arc: patch to check names imported from a module
  exists in the module
* Benjamin Niemann: patch to allow block level enabling/disabling of messages
* Nathaniel Manista: suspicious lambda checking
* Wolfgang Grafen, Axel Muller, Fabio Zadrozny, Pierre Rouleau,  
  Maarten ter Huurne, Mirko Friedenhagen (among others): 
  bug reports, feedback, feature requests...
* All the Logilab's team: daily use, bug reports, feature requests
* Other people have contributed by their feedback, if I've forgotten
  you, send me a note !