Pull requests

#84 Merged
Repository
dcollins4096/mhdct-extras mhdct-extras
Branch
week-of-code
Repository
enzo/enzo-dev enzo-dev
Branch
week-of-code

Making NumberOfGhostZones a run time parameter.

Author
  1. dcollins4096
Reviewers
Description

Two changes: 1.) DEFAULT_GHOST_ZONES gets renamed to NumberOfGhostZones to be consistent with Enzo naming convention 2.) NumberOfGhostZones becomes a run time parameter (changes to Read/WriteParameterFile, global_data, SetDefault)

I have been using this behavior for many years without problem, and it passed all test suites as of about one week ago.

  • Learn about pull requests

Comments (1)

  1. Michael Kuhlen

    Works as advertised. The quick test suite produces no failures besides the errors associated with ZEUS+SAB, which are already fixed in the tip of this repo. I'm going to accept.