Issue #87 resolved

Install error with python3

Atsushi Odagiri
created an issue

during installing fanstatic 1.0a4 in python 3.3, caught error:

Got fanstatic 1.0a4.
Getting distribution for 'which==1.1.3.py3'.
While:
  Updating wkiwki.
  Getting distribution for 'which==1.1.3.py3'.
Error: Couldn't find a distribution for 'which==1.1.3.py3'.

I found which at below::

But distributed version is 1.1.0. Which is which?

Comments (5)

  1. Jan-Jaap Driessen

    Fix issue #87 "install-error-with-python3": Fanstatic now depends on shutil.which when it's available (Python 3.3+) or uses shutilwhich library in other cases. This is useful because which.py is no longer supported.

    Thanks to Ivan Bulanov.

    → <<cset 9e7697c6c6e5>>

  2. Log in to comment