Exception using validator for user in project role

Issue #10 resolved
Former user created an issue

Hi,

I upgraded to Jira 6.0.1 and have an issue with one of the validators in the tool box.

I attached a screen shot of the validator.

When it is run I get the following error messagae...

Error creating issue: An unknown exception occured executing Validator com.fca.jira.plugins.workflowToolbox.UserInFieldInRolValidator@115a05ee: root cause: com.atlassian.jira.user.DelegatingApplicationUser cannot be cast to com.atlassian.crowd.embedded.api.User

Screen shot also attached

Thanks,

Mike

Comments (9)

  1. Fidel Castro Armario repo owner

    I have decided to remove declaration of compatibility with JIRA 6.0 to version 2.1 of JIRA Workflow Toolbox.

    As a workaround I have released version 2.1.1_beta_1 which solves current issue, but keep showing some incompatibilities with JIRA 6.0 in relation to custom field of type User Picker and Multi User Picker.

    I keep working on the plugin to release a version fully compatible with JIRA 6.

  2. Mike Wells

    Initial results of the beta release are good as far as I am concerned. Although now I have the fix from you it has exposed the exact same issue in some of my own scripts :-(

    Thanks for your quick response!

  3. Fidel Castro Armario repo owner

    I have just released version 2.1.1 of JIRA Workflow Toolbox. This new version of the plugin fixes current issue, and is the first version of the plugin fully compatible with JIRA 6.0.

  4. Log in to comment