Unable to copy contents of Account field from Epic to task in Epic

Issue #445 resolved
Helene Lund Engebø created an issue

Hi, I have a customer that uses Tempo Timesheets. When they have created an Epic, they set the Tempo Accounts field with the correct account.

When they create an issue (e.g. a task) within this Epic, they want the new task to inherit the Account from the Epic.

I have tried to achieve this by editing the create transition of the task's workflow, adding a "Read fields from linked issues or subtasks" post function: Source type: field in linked issues or subtasks. Field: Account [ Tempo Accounts Custom Field] Target field: Account [ Tempo Accounts Custom Field] Value to write in target field in case source field is of type Number etc: highest value Filtering by issue link type: has Epic * Filtering linked issues by issue type: Epic

This does not work - the value is not copied to the newly created task. I get the following error in the logs: 2016-11-16 14:39:16,819 http-nio-8080-exec-15 ERROR helene 879x4319x1 ea59wj 0:0:0:0:0:0:0:1 /secure/QuickCreateIssue.jspa [c.f.j.p.workflowToolbox.shared.WorkflowToolbox] *** Tempo Plugin is not available.

I have tried to edit the above post function, using Ephemeral number 1 as the target. Then creating another postfunction that writes the contents of Ephemeral number 1 to the issue description. This works - the correct Account ID is fetched. However I seem to be unable to set the Account field of the newly created task.

Tempo version: 8.1.1

Comments (6)

  1. Fidel Castro Armario repo owner

    Hi Helene,

    I would like to know the version of JIRA and JIRA Workflow Toolbox your customer is using.

    Thanks.

  2. Helene Lund Engebø reporter

    Hi! JIRA 7.1.2, JIRA Workflow Toolbox 2.2.25.

    Or actually, this is the versions in my local environment where I am testing this - the customer does not have a staging environment and I did not want to test this in production. The customer versions are JIRA 7.1.6, Tempo Timesheets , JIRA Workflow Toolbox 2.2.23, Tempo Timesheets 8.1.1.

  3. Fidel Castro Armario repo owner

    Hi Helen,

    The problem was introduced in version 2.2.18. It has been fixed in version 2.2.26_beta_1.

    Please, confirm that the problem has been solved for you. Thanks.

  4. Helene Lund Engebø reporter

    Yes! The beta version fixes the problem. When do you expect to release a production version containing a fix?

    Thanks for the quick response!

  5. Fidel Castro Armario repo owner

    The beta version only differs from 2.2.25 in this bug fix. It doesn't affect to anything else. You can install it in a production environment without concerns.

  6. Log in to comment