Crash - Alice's Challenge

Create issue
Issue #9 resolved
Jesse Kaukonen created an issue

I completed the first missions, played around the world map for a while, tried the menus, then went to the missions and accepted Alice's mission and the Hunting Lord Fizzy one. I then moved to Forest of Magic region and to the Cetnral Forest area, selected mission, and the game gave the "Errors occured" - message.

And yes, it seems to happen always. I tried lots of ways to go to the mission, even by starting a new game. It seems to always crash at the start of the mission

Traceback (most recent call last): File "srpg.py", line 88, in <module> File "engine.pyc", line 1327, in title_screen File "engine.pyc", line 1358, in launch_wm File "worldmap.pyc", line 429, in navigate_loop File "worldmap.pyc", line 385, in user_input File "worldmap.pyc", line 1076, in navigate_loop File "worldmap.pyc", line 1041, in user_input File "worldmap.pyc", line 1241, in menu_loop File "worldmap.pyc", line 1465, in execute File "worldmap.pyc", line 1354, in map_init KeyError: u'Agility+'

Comments (1)

  1. Rune Devros repo owner

    The bug was due to a change in trait naming conventions and this mission didn't get updated so it was trying to assign a trait to a character that didn't exist. It's been fixed now.

  2. Log in to comment