Commits

Anonymous committed 0702d4e

Using NUnit 2.5.5

  • Participants
  • Parent commits 6517818

Comments (0)

Files changed (6)

lib/Nunit/clr.bat

-@echo off
-rem Run a program under a particular version of the .Net framework
-rem by setting the COMPLUS_Version environment variable.
-rem
-rem This command was written by Charlie Poole for the NUnit project.
-rem You may use it separately from NUnit at your own risk.
-
-if "%1"=="/?" goto help
-if "%1"=="?" goto help
-if "%1"=="" goto GetVersion
-if /I "%1"=="off" goto RemoveVersion
-if "%2"=="" goto SetVersion
-goto main
-
-:help
-echo Control the version of the .Net framework that is used. The
-echo command has several forms:
-echo.
-echo CLR
-echo   Reports the version of the CLR that has been set
-echo.
-echo CLR version
-echo   Sets the local shell environment to use a specific
-echo   version of the CLR for subsequent commands.
-echo.
-echo CLR version command [arguments]
-echo   Executes a single command using the specified CLR version.
-echo.
-echo CLR off
-echo   Turns off specific version selection for commands
-echo.
-echo The CLR version may be specified as vn.n.n or n.n.n. In addition,
-echo the following shortcuts are recognized:
-echo   net-1.0, 1.0           For version 1.0.3705
-echo   net-1.1, 1.1           For version 1.1.4322
-echo   beta2                  For version 2.0.50215
-echo   net-2.0, 2.0           For version 2.0.50727
-echo.
-echo NOTE:
-echo   Any specific settings for required or supported runtime in 
-echo   the ^<startup^> section of a program's config file will 
-echo   override the version specified by this command, and the
-echo   command will have no effect.
-echo.
-goto done
-
-:main
-
-setlocal
-set CMD=
-call :SetVersion %1
-shift /1
-
-:loop 'Copy remaining arguments to form the command
-if "%1"=="" goto run
-set CMD=%CMD% %1
-shift /1
-goto :loop
-
-:run 'Execute the command
-%CMD%
-endlocal
-goto done
-
-:SetVersion
-set COMPLUS_Version=%1
-
-rem Substitute proper format for certain names
-if /I "%COMPLUS_Version:~0,1%"=="v"    goto useit
-if /I "%COMPLUS_Version%"=="net-1.0"   set COMPLUS_Version=v1.0.3705&goto report
-if /I "%COMPLUS_Version%"=="1.0"       set COMPLUS_Version=v1.0.3705&goto report
-if /I "%COMPLUS_Version%"=="net-1.1"   set COMPLUS_Version=v1.1.4322&goto report
-if /I "%COMPLUS_Version%"=="1.1"       set COMPLUS_Version=v1.1.4322&goto report
-if /I "%COMPLUS_Version%"=="beta2"     set COMPLUS_Version=v2.0.50215&goto report
-if /I "%COMPLUS_Version%"=="net-2.0"   set COMPLUS_Version=v2.0.50727&goto report
-if /I "%COMPLUS_Version%"=="2.0"       set COMPLUS_Version=v2.0.50727&goto report
-
-rem Add additional substitutions here, branching to report
-
-rem assume it's a version number without 'v'
-set COMPLUS_Version=v%COMPLUS_Version% 
-
-:report
-echo Setting CLR version to %COMPLUS_Version%
-goto done
-
-:GetVersion
-if "%COMPLUS_Version%"=="" echo CLR version is not set
-if NOT "%COMPLUS_Version%"=="" echo CLR version is set to %COMPLUS_Version%
-goto done
-
-:RemoveVersion
-set COMPLUS_Version=
-echo CLR version is no longer set
-
-:done

lib/Nunit/lib/Failure.jpg

Removed
Old image

lib/Nunit/lib/Gray.jpg

Removed
Old image

lib/Nunit/lib/Ignored.jpg

Removed
Old image

lib/Nunit/lib/Success.jpg

Removed
Old image

lib/Nunit/nunit-console.exe.config.bak

-<?xml version="1.0" encoding="Windows-1252"?>
-<configuration>
-	<!--
-     Application settings for NUnit-console.exe. Do NOT put settings
-	 for use by your tests here.
-	-->
-	<appSettings>
-	<!--
-	 Specify the location to be used by .NET for the cache
-	-->
-    <add key="shadowfiles.path" value="%temp%\nunit20\ShadowCopyCache" /> 
-	</appSettings>
-
-  <!-- Set the level for tracing NUnit itself -->
-  <!-- 0=Off 1=Error 2=Warning 3=Info 4=Debug -->
-  <system.diagnostics>
-	  <switches>
-      <add name="NTrace" value="0" />
-	  </switches>
-	</system.diagnostics>
-
-  <startup>  <requiredRuntime version="v4.0.20506" /></startup>
-  <runtime>
-    <loadFromRemoteSources enabled="true" />
-    <!-- We need this so test exceptions don't crash NUnit -->
-    <legacyUnhandledExceptionPolicy enabled="1" />
-
-    <!-- Look for addins in the addins directory for now -->
-    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
-      <probing privatePath="lib;addins"/>
-   </assemblyBinding>
-
-   <!--
-    The following <assemblyBinding> section allows running nunit under 
-    .NET 1.0 by redirecting assemblies. The appliesTo attribute
-    causes the section to be ignored except under .NET 1.0
-    on a machine with only the .NET version 1.0 runtime installed.
-    If application and its tests were built for .NET 1.1 you will
-    also need to redirect system assemblies in the test config file,
-    which controls loading of the tests.
-   -->
-   <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"
-			appliesTo="v1.0.3705">
-
-      <dependentAssembly> 
-        <assemblyIdentity name="System" 
-                          publicKeyToken="b77a5c561934e089" 
-                          culture="neutral"/>
-        <bindingRedirect  oldVersion="1.0.5000.0" 
-                          newVersion="1.0.3300.0"/>
-      </dependentAssembly>
-
-      <dependentAssembly> 
-        <assemblyIdentity name="System.Data" 
-                          publicKeyToken="b77a5c561934e089" 
-                          culture="neutral"/>
-        <bindingRedirect  oldVersion="1.0.5000.0" 
-                          newVersion="1.0.3300.0"/>
-      </dependentAssembly>
-
-      <dependentAssembly> 
-        <assemblyIdentity name="System.Drawing" 
-                          publicKeyToken="b03f5f7f11d50a3a" 
-                          culture="neutral"/>
-        <bindingRedirect  oldVersion="1.0.5000.0" 
-                          newVersion="1.0.3300.0"/>
-      </dependentAssembly>
-
-      <dependentAssembly> 
-        <assemblyIdentity name="System.Windows.Forms" 
-                          publicKeyToken="b77a5c561934e089" 
-                          culture="neutral"/>
-        <bindingRedirect  oldVersion="1.0.5000.0" 
-                          newVersion="1.0.3300.0"/>
-      </dependentAssembly>
-
-      <dependentAssembly> 
-        <assemblyIdentity name="System.Xml" 
-                          publicKeyToken="b77a5c561934e089" 
-                          culture="neutral"/>
-        <bindingRedirect  oldVersion="1.0.5000.0" 
-                          newVersion="1.0.3300.0"/>
-      </dependentAssembly>
-
-    </assemblyBinding>
-
-  </runtime>
-  
-</configuration>