Commits

Mark Lavin committed f9ab881

Notes on the current state of Django/Python support.

Comments (0)

Files changed (2)

 Installation Requirements
 -----------------------------------
 
-- `Django <http://www.djangoproject.com/>`_ >= 1.2
+- Python 2.6 or Python 2.7
+- `Django <http://www.djangoproject.com/>`_ >= 1.3
 - `jQuery <http://jquery.com/>`_ >= 1.4.4
 - `jQuery UI <http://jqueryui.com/>`_ >= 1.8
 
+.. note::
+
+    Begining with version django-selectable version 0.6, Django 1.2 is no longer supported.
+    While it may continue to work, bugs related to Django 1.2 support will not be fixed.
+
+
 Optional (but recommended)
 
 - `django-staticfiles <https://github.com/jezdez/django-staticfiles>`_
     
     pip install django-selectable
 
-If you are using `django-staticfiles` (or `django.contrib.staticfiles` in Django 1.3) then
-add `selectable` to your `INSTALLED_APPS` to include the related css/js.
+Next add `selectable` to your `INSTALLED_APPS` to include the related css/js::
+
+    INSTALLED_APPS = (
+        'contrib.staticfiles',
+        # Other apps here
+        'selectable',
+    )
 
 The jQuery and jQuery UI libraries are not included in the distribution but must be included
 in your templates. See the example project for an example using these libraries from the
 
 Once installed you should add the urls to your root url patterns::
 
-        urlpatterns = patterns('',
-            # Other patterns go here
-            (r'^selectable/', include('selectable.urls')),
-        )
+    urlpatterns = patterns('',
+        # Other patterns go here
+        (r'^selectable/', include('selectable.urls')),
+    )
 
 
 Documentation

docs/releases.rst

 v0.6.0 (Released TBD)
 --------------------------------------
 
+This release continues to clean up the API and JS. Python 2.5 support has been
+dropped to work towards Python 3 support. This also drops Django 1.2 support which
+is no longer receiving security fixes.
+
 Features
 _________________
 
 
 - ``get_item_value`` and ``get_item_id`` are no longer marked as safe by default.
 - Removed AutoComboboxSelectField and AutoComboboxSelectMultipleField. These were deprecated in 0.5.
+- Dropping Python 2.5 support
+- Dropping Django 1.2 support
 
 
 v0.5.2 (Released 2012-06-27)