qctool v2 -incl-variants flag does not work

Issue #44 invalid
Scott Ritchie
created an issue

When using the -incl-variants flag (e.g. to include only variants that I've manually identified as biallelic) qctool does not process any variants. When reaching the "Processing SNPs" step it runs for several minutes, processing at 0.0/s, then finishes without creating a new .bgen file.

qctool is able to run using the same text file of variants with -excl-variants.

Comments (2)

  1. Gavin Band repo owner

    Hi Scott, Thanks for the issue report. I can't reproduce this, e.g. using the bgen file in release/test/data/imputed.bgen, and an inclusions.txt file containing this:

    SNPID rsid chromosome position alleleA alleleB
    --- rs139652708 01 50000117 C T
    --- rs182437773 01 50002400 C T
     kgp9623959 01 50003586 G A
    --- chr3:50005509 01 50005509 T C
    --- rs114732077 01 50007407 C T
    

    And running: qctool_v2.0-rc9 -g release/test/data/imputed.bgen -incl-variants inclusions.txt -og -

    I get the correct output:

    ##fileformat=VCFv4.2
    ##FORMAT=<ID=GP,Type=Float,Number=G,Description="Genotype call probabilities">
    #CHROM  POS     ID      REF     ALT     QUAL    FILTER  INFO    FORMAT  sample_0        sample_1        sample_2        sample_3        sample_4
    01      50000117        rs139652708,--- C       T       .       .       .       GP      1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0
    01      50002400        rs182437773,--- C       T       .       .       .       GP      1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0
    01      50003586        kgp9623959      G       A       .       .       .       GP      1,0,0   1,0,0   1,0,0   0,1,0   1,0,0   1,0,0   1,0,0   0,1
    01      50005509        chr3:50005509,---       T       C       .       .       .       GP      1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0,0   1,0
    01      50007407        rs114732077,--- C       T       .       .       .       GP      1,0,0   1,0,0   1,0,0   1,0,0...
    

    Outputting to a bgen file also works. Can you please attach more info on your specific problem? Best, g.

  2. Log in to comment