Issue #12 resolved

Conflict with system virtualenv

Preston Timmons
created an issue

Hey Gael,

I've been using this recipe for a while and it's worked great but I tried to run the buildout on a different server and got this error:

TypeError: create_environment() got an unexpected keyword argument 'use_distribute'

It turns out an old version of virtualenv was installed in the system Python and the recipe was trying to use that.

Do you think you could update the requirements file in setup.py to set a minimum version for virtualenv? Setting it to "virtualenv>=1.4" would fix this problem. That's the version that the distribute options was added.

Thanks.

Comments (1)

  1. Log in to comment