GECO Crashes on Open or Save As

Issue #36 wontfix
Leif Bloomquist created an issue

Using the latest version, 1.2.1 and the latest LEAP drivers (as far as I can tell). GECO works fine, it's seeing my inputs and producing MIDI as it should. It loads the last document on startup just fine. I can also use Open Recent.

But I can't Open or "Save As" my settings. It simply crashes (see screenshot). So it's pretty unusable at this point.

I suppose I could reverse-engineer the .geco format (fortunately it's just XML) but the GUI is much better!

Machine is Windows 7 64-bit with 8GB RAM, 6-core i7 @ 2.2 Ghz (An Alienware M14x if you want the specific model).

I tried uninstalling/reinstalling through Airspace, no change.

Comments (13)

  1. Leif Bloomquist reporter

    You can see in the System Tray all the leftover icons from past crashes! :-) (It's not running multiple instances)

  2. Geert Bevin repo owner

    What did you launch as administrator, Airspace or GECO? Can you try with launching GECO as admin?

    So it always crashes when you're supposed to see a file dialog? Does regular Save work?

  3. Leif Bloomquist reporter

    It's Airspace that I run as Administrator. But GECO still sometimes crashes on Open/Save As. Sometimes it works. I'm not sure why yet.

    Running GECO as Administrator directly outside of Airspace (I have it pinned to my taskbar) doesn't seem to make a difference (still crashes).

    Good point re. the file dialog. Regular Save does work.

  4. Geert Bevin repo owner

    TTPreso.exe is part of the Leap Motion distribution package as created by Airspace, I have no idea what it does, they just add it :-)

  5. Geert Bevin repo owner

    If regular Save works, there's a way to get you unstuck for now I think. You can drag and drop a .geco file onto the application to open, or even double-click a file. If you copy and rename an existing .geco beforehand, you can have many different ones. I'll try to figure out why you might be seeing these crashes, I can't reproduce them :-(

  6. Geert Bevin repo owner

    I'm trying to pin-point the problem here, could it be that you have something installed that interferes with the standard system file chooser, maybe making it behave differently than expected. The actual FileChooser display part is not something that is coded explicitly in GECO, it's part of the underlying library that we're using (Juce). So I'll have to channel this back to the developer of Juce. Also, I've been trying since your report, and I can't reproduce this so it's very hard at this time to understand why this might be happening.

  7. Leif Bloomquist reporter

    Understood. Drag and drop does work - I had never even thought of that. So that's an acceptable workaround for now. Thanks!

  8. Geert Bevin repo owner

    Could you please comment on possibly having having something installed that interferes with the standard system file chooser, maybe making it behave differently than expected?

  9. Leif Bloomquist reporter

    I did have a Windows theme pack (custom folders icons, etc) installed a while back, but uninstalled it - perhaps something from it got left over.

  10. Log in to comment