Shutdown Bug

Issue #49 new
james doviak created an issue

Some bug reporting for you here. I'm on a Macbook pro late 2013, OS 10.9.5 and running GecoMidi 1.3.0. After running a session with Logic 9.1.3 a few times after quitting Geco, the app is gone from the activity monitor, but the icon still shows up when toggling through applications and it seems to prevent shutdown and /or logouts too, requiring a manual computer shutdown holding the power key down. If i pull up the force quit window Geco shows up there but I am unable to quit it. It is as if some small part of the program is still being seen as running after the main part has quit. After a restart and just loading up Geco it's no problem and will quit as normal. I haven't figured out yet if the problem is related to some interaction with Logic but will experiment further.

Comments (5)

  1. Jonathan Rodgers

    I'm having the same problem, and I have a similar setup. Macbook Pro 10.9.5. Pro Tools. Leap Motion. I was running GecoMIDI 1.2.4, and I've just tried updating to 1.3.0

    Same exact complaint as the user above. Except that when I restart the computer after a manual shutdown, Geco is still in that "limbo" state; perhaps because I have a computer start default of opening apps that were open upon shutdown.

    Any resolve on this?

    J Rodgers

  2. Renee Cologne

    Has this issue ever been resolved? I see these posts are from a year ago. . . I have a 3.4 GHz Intel Core i7 iMac 10.9.5. GecoMidi 1.3.0. Plugged it in and did the 'pick the flower petal' app. Tried to quit the program, GecoMidi won't close. When I try to re-open it after re-starting, I get a "The application GecoMidi.app can't be opened. -600" message. No other apps are open. Computer won't shut down unless manually holding down the power key.

    Please tell me that after a year, there was a fix on this? Thanks,

    Renee

  3. james doviak reporter

    Sadly not aware of any resolution, although I haven't used the app for a year and I believe there is an update, but whether it makes a difference I can't say!

  4. Geert Bevin repo owner

    Sadly we're not able to reproduce this. We're working on a minor update that has some small stability improvements. Hopefully this will fix this issue.

  5. roman Pogorzelski

    same problem another year later. its annoying to shut down the Mac manually and i bet its not good too but i found no workaround than deleting and reinstalling GECO.

  6. Log in to comment