Commits

Michael Granger committed 60d2a8f

Update dependencies, remove 'fivefish' formatter from the spec.

  • Participants
  • Parent commits a2a3750

Comments (0)

Files changed (4)

 ^coverage.info$
 ^ChangeLog$
 ^pkg/
+^Gemfile\.lock$
-# .rvm.gems generated gem export file. Note that any env variable settings will be missing. Append these after using a ';' field separator
-highline -v1.6.13
-hoe-deveiate -v0.1.1
+highline -v1.6.19
+hoe -v3.7.0
+hoe-bundler -v1.2.0
+hoe-deveiate -v0.3.0
+hoe-highline -v0.1.0
 hoe-manualgen -v0.3.0
-hoe-bundler -v1.2.0
-loggability -v0.4.0
-rack-test -v0.6.1
-rdoc -v3.12
-rspec -v2.10.0
-simplecov -v0.6.4
-sinatra -v1.3.2
-tilt -v1.3.3
-sysexits -v1.0.2
+hoe-mercurial -v1.4.0
+loggability -v0.6.1
+rack-test -v0.6.2
+rdoc -v4.0.1
+simplecov -v0.7.1
+sinatra -v1.4.3
+sysexits -v1.1.0
+tilt -v1.4.1
 trollop -v1.16.2
-loggability -v0.5.0
 gem "rack-test", "~>0.6", :group => [:development, :test]
 gem "simplecov", "~>0.6", :group => [:development, :test]
 gem "sinatra", "~>1.3", :group => [:development, :test]
-gem "tilt", "~>1.3", :group => [:development, :test]
+gem "tilt", "~>1.4", :group => [:development, :test]
 gem "sysexits", "~>1.0", :group => [:development, :test]
 gem "trollop", "~>1.16", :group => [:development, :test]
-gem "hoe", "~>3.6", :group => [:development, :test]
+gem "hoe", "~>3.7", :group => [:development, :test]
 
 # vim: syntax=ruby
 	self.readme_file = 'README.rdoc'
 	self.history_file = 'History.rdoc'
 	self.extra_rdoc_files << 'README.rdoc' << 'History.rdoc'
+	self.license "BSD"
 
 	self.developer 'Michael Granger', 'ged@FaerieMUD.org'
 	self.developer 'Mahlon E. Smith', 'mahlon@martini.nu'
 	self.dependency 'loggability',   '~> 0.4'
 
 	self.dependency 'highline',      '~> 1.6',  :development
-	self.dependency 'hoe-deveiate',  '~> 0.2',  :development
+	self.dependency 'hoe-deveiate',  '~> 0.3',  :development
 	self.dependency 'hoe-bundler',   '~> 1.2',  :development
 	self.dependency 'rack-test',     '~> 0.6',  :development
 	self.dependency 'simplecov',     '~> 0.6',  :development
 	self.dependency 'sysexits',      '~> 1.0',  :development
 	self.dependency 'trollop',       '~> 1.16', :development
 
-	self.spec_extras[:licenses] = ["BSD"]
-	self.spec_extras[:rdoc_options] = ['-f', 'fivefish', '-t', 'Inversion Templates']
 	self.require_ruby_version( '>=1.9.2' )
 	self.hg_sign_tags = true if self.respond_to?( :hg_sign_tags= )
 	self.check_history_on_release = true if self.respond_to?( :check_history_on_release= )