Commits

Michael Granger committed a116fb6

Update dependencies, add Gemfile.

Comments (0)

Files changed (4)

 ^pkg/
 var/
 \.foreman$
+Gemfile.lock
-# .gems generated gem export file. Note that any env variable settings will be missing. Append these after using a ';' field separator
 amalgalite -v1.3.0
-configurability -v2.0.0
-hoe-deveiate -v0.1.1
-nokogiri -v1.5.5
-sequel -v4.0.0
+configurability -v2.1.0
+hoe -v3.7.1
+hoe-bundler -v1.2.0
+hoe-deveiate -v0.3.0
+loggability -v0.7.0
+nokogiri -v1.6.0
+rdoc -v4.0.1
+sequel -v3.48.0
 simplecov -v0.7.1
+sqlite3 -v1.3.8
 sysexits -v1.1.0
 tnetstring -v0.3.4
 trollop -v2.0
 yajl-ruby -v1.1.0
 zmq -v2.1.4
-loggability -v0.5.0
-inversion -v0.12.2
+# -*- ruby -*-
+
+# DO NOT EDIT THIS FILE. Instead, edit Rakefile, and run `rake bundler:gemfile`.
+
+source "https://rubygems.org/"
+
+gem "nokogiri", "~>1.5"
+gem "sequel", "~>3.44"
+gem "tnetstring", "~>0.3"
+gem "yajl-ruby", "~>1.0"
+gem "trollop", "~>2.0"
+gem "sysexits", "~>1.1"
+gem "zmq", "~>2.1"
+gem "loggability", "~>0.5"
+gem "sqlite3", "~>1.3"
+
+gem "hoe-mercurial", "~>1.4.0", :group => [:development, :test]
+gem "hoe-highline", "~>0.1.0", :group => [:development, :test]
+gem "rdoc", "~>4.0", :group => [:development, :test]
+gem "configurability", "~>2.0", :group => [:development, :test]
+gem "simplecov", "~>0.7", :group => [:development, :test]
+gem "hoe-deveiate", "~>0.3", :group => [:development, :test]
+gem "hoe-bundler", "~>1.2", :group => [:development, :test]
+gem "hoe", "~>3.7", :group => [:development, :test]
+
+# vim: syntax=ruby
 Hoe.plugin :mercurial
 Hoe.plugin :signing
 Hoe.plugin :deveiate
+Hoe.plugin :bundler
 
 Hoe.plugins.delete :rubyforge
 
 	self.readme_file = 'README.rdoc'
 	self.history_file = 'History.rdoc'
 	self.extra_rdoc_files = Rake::FileList[ '*.rdoc' ]
+	self.license 'BSD'
 
 	self.developer 'Michael Granger', 'ged@FaerieMUD.org'
 
 	self.dependency 'loggability','~> 0.5'
 	self.dependency 'sqlite3',    '~> 1.3'
 
+	self.dependency 'amalgalite',      '~> 1.3', :developer
 	self.dependency 'configurability', '~> 2.0', :developer
 	self.dependency 'simplecov',       '~> 0.7', :developer
-	self.dependency 'hoe-deveiate',    '~> 0.1', :developer
+	self.dependency 'hoe-deveiate',    '~> 0.3', :developer
+	self.dependency 'hoe-bundler',     '~> 1.2', :developer
 
-	self.spec_extras[:licenses] = ["BSD"]
 	self.spec_extras[:rdoc_options] = ['-f', 'fivefish', '-t', 'Mongrel2 Ruby Connector']
 	self.require_ruby_version( '>= 1.9.2' )