Issue #88 resolved

pg-0.11.0 does not build native extension against ruby-1.9.3rc1

Sven Schwyn
created an issue

I'm trying to install the pg gem on a Gentoo box with postgresql-9.0.5 and ruby-1.9.3rc1. Here's what make has to say:

{{{ Using config values from /usr/bin/pg_config checking for libpq-fe.h... yes checking for libpq/libpq-fs.h... yes checking for PQconnectdb() in -lpq... yes checking for PQconnectionUsedPassword()... yes checking for PQisthreadsafe()... yes checking for PQprepare()... yes checking for PQexecParams()... yes checking for PQescapeString()... yes checking for PQescapeStringConn()... yes checking for PQgetCancel()... yes checking for lo_create()... yes checking for pg_encoding_to_char()... yes checking for PQsetClientEncoding()... yes checking for struct pgNotify.extra in libpq-fe.h... yes checking for unistd.h... yes creating extconf.h creating Makefile

make compiling compat.c compiling pg.c pg.c: In function ‘pgconn_wait_for_notify’: pg.c:2105:3: warning: ‘rb_thread_select’ is deprecated (declared at /usr/include/ruby-1.9.1/ruby/intern.h:379) pg.c: In function ‘pgconn_block’: pg.c:2589:3: warning: ‘rb_thread_select’ is deprecated (declared at /usr/include/ruby-1.9.1/ruby/intern.h:379) linking shared-object pg_ext.so pg.o: In function find_or_create_johab': pg.c:(.text+0x4e): undefined reference torb_enc_alias' pg.c:(.text+0x61): undefined reference to `rb_enc_alias' collect2: ld returned 1 exit status make: *** [pg_ext.so] Error 1 }}}

Any chance there might be an easy fix for this?

Thanks a bunch, -sven

Comments (5)

  1. Anonymous

    Just a little followup: Any chance this patch gets released as 0.12 or a 0.12pre gem in the near future?

  2. Log in to comment