Cannot build pg 0.12.2 on CentOS-5.7 with pgdg-9.1.2 installed

Issue #102 invalid
Anonymous created an issue

This is a note for people building the pg gem on RHEL derivative systems and who are using the pre-compiled v.9.1 binary rpms from pgrpms.org.

As shipped the program pg_config is installed in /usr/pgsql-9.1/bin/ and no link to this binary is made in any of the directories usually in the $PATH environment variable. Because of this the make configuration cannot find the necessary libraries and the build fails.

Adding a link from /usr/local/bin/pg_config to /usr/pgsql-9.1/bin/pg_config resolves the problem.

{{{ # ln -s /usr/pgsql-9.1/bin/pg_config /usr/local/bin/pg_config }}}

This really is not a bug or enhancement but, I do not know where else I could put this information that is is more suitable.

James B. Byrne ( byrnejb --at-- harte-lyne --dot-- ca )

Comments (1)

  1. Log in to comment