1. Michael Granger
  2. ruby-pg

Issues

Issue #143 invalid

Can't find the PostgreSQL client library (libpq)

allspiritseve
created an issue

I'm having trouble installing the pg gem on my laptop running Linux Mint 13.

Here's what I get: http://pastebin.com/WZakAtaA

Here's the contents of the mkmf.log file: http://pastebin.com/VwiLS4VH

The most common recommendation seems to be to install libpq-dev, which I've done to no effect.

I'm happy to provide any extra info needed to track down this issue.

Comments (5)

  1. Michael Granger repo owner

    Your mkmf.log shows that the OpenSSL library that was linked against your libpq isn't being found for some reason. Did it get updated or moved? If you do `ldd /usr/lib/libpq.so`, where is it pointing to for `libssl` and `libcrypto`?

  2. allspiritseve reporter

    This is a fresh install from today, so the openssl library did not get updated or moved.

    libssl.so.1.0.0 => /lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007ffb1488b000) libcrypto.so.1.0.0 => /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007ffb144c3000)

  3. Michael Granger repo owner

    Oh good. I should add a section to the README on troubleshooting installs via RVM, as that seems to be the cause of the problem about half the time. :/

    Thanks for following up!

  4. Log in to comment