1. Michael Granger
  2. ruby-pg
  3. Issues

Issues

Issue #152 invalid

Symbol not found: _rb_eEncCompatError

Anonymous created an issue

ruby 1.8.7 (2012-10-12 patchlevel 371) [i686-darwin12.2.0] pg-0.14.1

I get the following: $ ruby script/console Loading development environment (Rails 2.3.17) /Users/grahamsavage/gemz/gems/activerecord-2.3.17/lib/active_record/connection_adapters/abstract/connection_specification.rb:76:in establish_connection':RuntimeError: Please install the postgresql adapter:gem install activerecord-postgresql-adapter(dlopen(/Users/grahamsavage/gemz/gems/pg-0.14.1/lib/pg_ext.bundle, 9): Symbol not found: _rb_eEncCompatError Referenced from: /Users/grahamsavage/gemz/gems/pg-0.14.1/lib/pg_ext.bundle Expected in: flat namespace in /Users/grahamsavage/gemz/gems/pg-0.14.1/lib/pg_ext.bundle - /Users/grahamsavage/gemz/gems/pg-0.14.1/lib/pg_ext.bundle) /Users/grahamsavage/gemz/gems/activesupport-2.3.17/lib/active_support/dependencies.rb:131:inconst_missing':NameError: uninitialized constant ApplicationController::ExceptionNotification

I also get: $ otool -Iv pg_ext.bundle | grep rb_eEnc 0x000000000000e030 892 _rb_eEncCompatError

and you can clearly see it exists.

I've installed and reinstalled the PG gem several times with a few different options.

Comments (2)

  1. Log in to comment