1. Michael Granger
  2. ruby-pg
  3. Issues

Issues

Issue #167 invalid

When will gem 'pg' work with rails 4.0?

Anonymous created an issue

I used 'gem install pg' and then ran bundle install on my current hobo 2.0 project only to find out that the current version of the pg gem only supports rails 3.2 and not 4.0. according to the error message. I'm using a machine with LinuxMint Cinnamon 15 and everything else seems to be working. Would sure like to start using rails 4 with PostGreSQL! Any ideas?

Comments (3)

  1. Michael Granger repo owner

    Since ActiveRecord depends on 'pg' and not the other way around, it's not true to say that pg "supports" any version of Rails. That said, we'd be interested in hearing about any incompatibilities. We've worked closely with Aaron Patterson (tenderlove) in the past on a few things specifically for ActiveRecord, so I'd be surprised if he didn't mention a problem with Rails 4.

  2. Log in to comment