Can`t install pg - dependency

Issue #176 invalid
Hristo Mihov
created an issue

Hello,

When i try to install pg gem i receive this error Can't find the 'libpq-fe.h header extconf.rb failed

libpq-fe.h is a part from libpq, but I`ve already installed libpq5, and there are some dependency between them. I cant remove libpq5 because it will remove postgress client packages, and psql cant be accessed. Is there any solution for this dependency.

Comments (2)

  1. Lars Kanis

    You must install the libpq development files in order to install pg. The package is called libpq-dev or something like, depending on the distribution you're using.

  2. Log in to comment